BIG Hello

OSPF states for adjacency formation are Down, Init, Attempt, 2-way, Exstart, Exchange, Loading and Full. There can be number of reasons why the Open Shortest Path First (OSPF) neighbors are stuck in exstart/exchange state, while one of the many reason is on an MTU mismatch between OSPF neighbors resulting in exstart/exchange state.

Since the problem is caused by mismatched MTUs, the solution is to change either router MTU to match the neighbor MTU.

Note that Cisco IOS does not support a chang of the physical MTU on a LAN interface (such as Ethernet or Token Ring). When the problem occurs between a Cisco router and another vendor router over LAN media, adjust the MTU on the other vendor router.

or use, in Cisco IOS Software 12.01(3), the ip ospf mtu-ignore interface configuration command, to turn off the MTU mismatch detection.

However, in Dual ISIS, By default, IS-IS hellos are padded to the full maximum transmission unit (MTU) size,

The benefit of padding IIHs to the full MTU is early detection of errors caused by transmission problems with large frames or MTU mismatched on adjacent interfaces.

from a high level, IS-IS operates as follows

Routers running IS-IS will send hello packets out all IS-IS-enabled interfaces to discover neighbors and establish adjacencies.

Routers sharing a common data link will become IS-IS neighbors if their hello packets contain information that meets the criteria for forming an adjacency. The criteria differ slightly depending on the type of media being used (p2p or broadcast). The main criteria are matching authentication, IS-type and MTU size).

Routers may build a link-state packet (LSP) based upon their local interfaces that are configured for IS-IS and prefixes learned from other adjacent routers.

Generally, routers flood LSPs to all adjacent neighbors except the neighbor from which they received the same LSP. However, there are different forms of flooding and also a number of scenarios in which the flooding operation may differ.

All routers will construct their link-state database from these LSPs.

A shortest-path tree (SPT) is calculated by each IS, and from this SPT the routing table is built.

Sending full size MTU (1500 bytes or any  other Jumbo Sized frames) , Padded Hellos to neighboring routers, would hit direclty on the  performance of the router,  the CPU has no other choice but to process this Big ISIS Hello message received from neighbors, every 10-second hello interval, with the exception of a broadcast segment’s in which the designated router, sends hellos at one-third the normal interval (every 3.3 seconds),  and last but not least,  on low-speed, sending interfaces large hello PDUs is a waste bandwidth!! This off course affects time-sensitive applications such as voice over IP (VoIP).

The padding of IIHs can be turned off (in Cisco IOS® Software Releases 12.0(5)T and 12.0(5)S) for all interfaces on a router with the no hello padding command in router configuration mode for the IS-IS routing process. The padding of IIHs can be selectively turned off for point-to-point or multipoint interfaces with the no hello padding multi-point orno hello padding point-to-point command in router configuration mode for the IS-IS routing process. Hello padding can also be turned off on an individual interface basis using theno isis hello padding interface configuration command. – or you can use clsn mtu to solve the MTU issues –

sendingfullhello

hellopadding

now after this configuration:

nohellopadding

routers are not sending/receiving anymore those BIG padded ISIS Hellos.. they just send 43 bytes + Layer2 encapsulation to neighboring router.

notsendingfullhello

A Networker Blog

IS-IS for Spanish People

Otro post en mi blog con relacion a esto

Motivo de ISIS

Fue diseñado para IGP conecctionless network, parte de OSI, IP se monta sobre CLNS, (Connectionless Network Service), las direcciones CLNS se llaman NSAP (20 bytes Network Service Access Point), el protocolo de capa 3 en is-is era CLNP para la torre OSI, (connectionless network protocol), La LinkState Data Base se construye corriendo el algoritmo Dijkstra basándose en direcciones CLNS(Connectionless Network Service).

Similitudes con OSPF es que es un protocolo de de estado de enlace (link state), Soporta VLSM y utiliza el algoritmo de Dijkstra para determinar el camino mas corto

Usa “Hello” para establecer adyacencias y LSP para intercambiar la información del estado del enlace, asi como se usa eficiente el BW, memoria y uso de CPU

Soporta dos niveles de routing

Level1: Routing con una area y solo dentro de esta area, los routers L1, solo halan con routers de ltipo L1 sólo

El área se denomina con “AFI/IDI”, (como si fuera el area0 ó 1 de OSPF)

Route Leaking (filtracion de rutas) para trasvasar rutas de L2 a L1

Un area dentro de IS-IS, pertenece al roiuter no al interface

Level2: Routing entre areas, intercambia prefijos de informacion, (direcciones de area) entre aéreas, el tráfico hacia el área usa “lowest-cost path”

Para transportar IP se utiliza “Integrated IS-IS” o “Dual IS-IS”

Is-IS utiliza su propio PDU para transportar información, se requiere direccionamiento CLNS aunque estemos transportando IP.

Se puede sumarizar, limitando la inundación (flooding), de LSP (link state packets), estos vienen identificados con unos TLVS, se le puede asignar hasta 15 TLB de profundidad

Entre esto conseguimos los siguentes Hellos

IIH(is to is hellos)

ES-IS(End system to intermediate system)

L0 es cuando un end system se comunica con router L1 de su área

L1 es cuando un router se comunica con otro router de su area

L2 es cuando cuando un end system se comunica con otra área

L3 es cuando se comunica con otro dominio

NET (Network entity title) es un identificador parecido al router-id en OSPF

TLV (type Lenght Value), forma parte del LSP

CLNS –> TLV y dependen del código del TLV podríamos saber que tipo de ruta estamos transportando —> asi que IP, se monta arriba de los paquetes CLNS (Piggybacking- como de caballito)

Todos los links en ISIS por defecto tienen una métrica de 10, soportándose la métrica narrow resumida a 6 bit para la métrica de una interfaz así como 10 bits para el costo de un camino (Path Cost) origen hasta el destino. En las implementaciones 12.0 y en adelante se puede soportar de una métrica wide (expandida) donde soportamos métrica de interfaz de hasta 24 bits y para el costo del camino (total numero de saltos por interfaces de origen a destino) 32 bits.

Un poco más acerca del Path Cost y al tener confirados 10 como costo en las interfaces por su configuración defecto, podríamos ver que su comportamiento por defecto es como RIP utiliza el hop count para llegar a su destino (Path Vector Rulez!)

En ISIS los Routers Cisco soportan solo la métrica Default, entre Errors, Expense, Delay y default, En Implementaciones Cisco, actualmente solo esta soportado la Métrica Default.

Direcciones OSI:

NSAP (Network Service Access Points) divide su estructura o direccionamiento en 20 bytes en una parte de alto nivel y otra de bajo nivel

la alta indica Describe los Initial Domain Part (AFI y IDI)

La baja identifica el nodo dentro de l area

En la parte alta esta

AFI (authority formal identifier), IDI (initial domain identifier) , High Order DSP, System ID, NSEL(Nselector, identifica quer dispositivo de capa 3 es dentro de ISIS si su valor es 00 )

Cisco lo toma como un valor global de area y el nslector como el servico que el dispositivo está prestando dentro de la red.

El Direccionamiento NSAP, Se lee al revés, de derecha a Izquierda, los routers empiezan con el NSEL (Network-Selector), el ID del Systema, y el resto que es variable representaría el area donde se encuentre este dispositivo.

Estructura típica de direcciones NSAP:

AFI : 39 para un país completo a 47 para comunicaciones internacionales, 43 ó 57 para comunicaciones de telefono, 57 para ISDN, y 49 para indicar un dominio privado

System ID: se podría utilizar una dirección MAC del router al momento de su planificación, asi como también un valor representativo en alguna estructura de diseño

NSEl: 00 para identificar un router

La dirección de área identifica el area de routing, y el system ID identifica el nodo, todos los routers del mismo area deben tener la misma dirección de área, la dirección de área se usa en el routing de L2

SNPA es como (subnetwork point of attachment) es para resolver direcciones L3 de NSAP

SNPA es L2 y NSAP es L3

Piggy Backing (es como el encapsulamiento), en IS-IS sería Ethernet montado en CLNS, CLNS sobre TLV y este sobre IP.

Los routers L1 comparan el área address (AFI/ID), si no es igual se envía al L2 más cercano, si es igual se utiliza la LSBD de L1 por que esta en nuestro area

Route leaking (es redistribuir L2 dentro de L1) para que los routers L1 tengan información mas precisa que sólo con la métrica para salir de su área, todos estos mensajes se comunican a través de un PDU, y esta estructurado:

Data-link-header (0xFEFE) / IS-IS header 0x83 / IS-IS TLVs donde ecapsulamos directamente sobre Ethernet, Frame Relay, etc. Suelen ser Hellos, los LSP (Link state packets), los PSNO, (utilizados para obtener porciones de la topologia) y los CSNP (complete sequence number PDU)

Un LSP es:

LSP header / TLV Neighbors / TLV Neighbors / TLV ……..(aqui es donde se monta IP)

Los headers del LSP incluyen: tipo, longitud, numero de secuencia, permiten sincronización, decremento de tiempo

IS-IS solo ve dos tipos de interfaces, broadcast y pto pto, no tiene concepto de Non Broadcast MultiAccess

En las redes broadcast se designa un DIS (es como un DR en OSPF)

DIS (Designates Intermedia System), funciona como un pseudonodo y representa la LAN, se elige en base al interfaz con prioridad mas alta y mac mas alta, recorta las publicaiones de networks advertisement

Existen dos niveles de LSP, LSP se envían como unicast para interfaces pto a pto y en broadcast se envían como multicast

Broadcast

Point-to-Point

Usage

LAN full-mesh wan

PPP, HDLC, partial mesh wan

Hello timer

3,3 sec for DIS else 10 sec

10 sec

Adjacencies

n(n-1)/2

n-1

Uses DIS

Yes

No

IIH type

Level 1 IIH

Level 2 IIH

Point-to-point IIH

Sincronización de la LSDB

Con un numero de secuencia (SNP), PSNP (Partial sequence number PDU) se hace acknowledgment en pto a pto y en LAN pide informacion que no recibio un LSP en particular al representante de este segmento Bradcast, es decir hacia el DIS.

los CSNP se envian por el DIS cada 10 sec para mantener la sincronización, y en pto a pto una sola vez.

Cuando se pierde un LSP el router que lo perdió envía un PSNP para solicitar el reenvió de información.

Cuando en pto a pto un enlace se cae con un LSP se envía la actualización y el ack se contesta con un PSNP

Configuración de ISIS en cisco:

router isis [area tag] —>es un nombre por ej telefonica, es una etiqueta local

net (network-entity-title) –> 49.0001.111111111111.00

ip router isis [area-tag] –> este comando en las ifzs, si o se especifica esta en L1-L2

En router isis:

is-type (level-1 | level-1-2 | level-2-only)

para hacer esto dentro de las Ifzs: isis circuit-type {level1 | level1-2 | level-2-only}

config del lab de ISIS

interface Loopback0

ip address 4.4.4.4 255.255.255.255

ip router isis —> si no se pone no se habilita

isis circuit-type level-1

interface FastEthernet0/0

ip address 10.2.2.4 255.255.255.0

ip router isis

ip ospf network broadcast

duplex auto

speed auto

router isis

net 49.0018.4444.4444.4444.00

is-type level-1



A Networker Blog

BGP Keepalives

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804435fc.html

Since BGP uses TCP session, there is no way to verify the presence of a BGP Neighbor, except when sending BGP Traffic, so BGP sends keepalives every 60 seconds

Keepalive interval value is not communicated in the BGP Open Message

Default Values:
Keepalive 60 Seconds
HoldTime 180 Seconds

NOTE:

BGP does not use any transport protocol-based keep-alive mechanism to determine if peers are reachable. Instead, KEEPALIVE messages are exchanged between peers often enough as not to cause the Hold Timer to expire. A reasonable maximum time between KEEPALIVE messages would be one third of the Hold Time interval. KEEPALIVE messages MUST NOT be sent more frequently than one per second. An implementation MAY adjust the rate at which it sends KEEPALIVE

Example of this:

R3 and R4 in AS 34

R3 and R4 in AS 34


Smaller integer in relation to (holtime/3), if holdtime of neigh is used and keepalive > (holdtime/3)

R3#
router bgp 34
timers bgp 15 30

R3#show ip bgp neigh | in keep
Last read 00:00:06, last write 00:00:06, hold time is 30, keepalive interval i
s 10 seconds
Configured hold time is 30,keepalive interval is 15 seconds, Minimum holdtime
from neighbor is 0 seconds
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:02, last write 00:00:02, hold time is 30, keepalive interval i
s 10 seconds

Notice the configured Keepalive (15) in R3 and the selected keepalive in R4 10 seconds, but R3 is using 10 as the keepalive, since is the lowest keepalive (holdtime /3)

Another example

R3(config-router)#timer bgp 20 30
R3(config-router)#do clear ip bgp *

R3(config-router)#do show ip bgp neigh | in keep
Last read 00:00:07, last write 00:00:07, hold time is 30, keepalive interval i
s 10 seconds
Configured hold time is 30,keepalive interval is 20 seconds, Minimum holdtime
from neighbor is 0 seconds
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:05, last write 00:00:05, hold time is 30, keepalive interval i
s 10 seconds

Notice now that R3 had been configured with 20 of keepalive and 30 of holdtime
and the selected values are 30 and 10

if the holddtime interval of the neigbor is selected and the locally configured keepalive is less than a third of the holdtime intercal the peers use the locally configured keep alive

R3(config-router)#timer bgp 9 30
R3(config-router)#do clear ip bgp *
R3(config-router)#
*Nov 17 16:31:25.853: %BGP-5-ADJCHANGE: neighbor 1.1.1.4 Down User reset
R3(config-router)#
*Nov 17 16:31:27.885: %BGP-5-ADJCHANGE: neighbor 1.1.1.4 Up
R3(config-router)#do show ip bgp neigh | in keep
Last read 00:00:06, last write 00:00:06, hold time is 30, keepalive interval i
s 9 seconds
Configured hold time is 30,keepalive interval is 9 seconds, Minimum holdtime f
rom neighbor is 0 seconds
R3(config-router)#
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:01, last write 00:00:08, hold time is 30, keepalive interval i
s 10 seconds

Another Example

R4(config-router)#timer bgp 7 60
R4(config-router)#do clear ip bgp *
R4(config-router)#
%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Down User reset
%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Up
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:04, last write 00:00:05, hold time is 30, keepalive interval i
s 7 seconds
Configured hold time is 60,keepalive interval is 7 seconds, Minimum holdtime f
rom neighbor is 0 seconds
R4(config-router)#
R3(config-router)#do show run | in timer
timers bgp 9 30
R3(config-router)#do show ip bgp neigh | in keep
Last read 00:00:05, last write 00:00:03, hold time is 30, keepalive interval i
s 9 seconds
Configured hold time is 30,keepalive interval is 9 seconds, Minimum holdtime f
rom neighbor is 0 seconds
R3(config-router)#
R4(config-router)#timer bgp 11 60
R4(config-router)#do clear ip bgp *

%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Down User reset
%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Up
R4(config-router)#do show ip bgp

R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:07, last write 00:00:07, hold time is 30, keepalive interval i
s 10 seconds
Configured hold time is 60,keepalive interval is 11 seconds, Minimum holdtime
from neighbor is 0 seconds
R4(config-router)#
R4(config-router)#no timers bgp 11 60
R4(config-router)#do clear ip bgp *
%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Down User reset
%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Up
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:04, last write 00:00:04, hold time is 30, keepalive interval i
s 10 seconds
R4(config-router)#
R3(config-router)#timers bgp 11 40
R3(config-router)#do clear ip bgp *
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:03, last write 00:00:02, hold time is 40, keepalive interval i
s 13 seconds
R3(config-router)#do show ip bgp neigh | in keep
Last read 00:00:00, last write 00:00:09, hold time is 40, keepalive interval i
s 11 seconds
Configured hold time is 40,keepalive interval is 11 seconds, Minimum holdtime
from neighbor is 0 seconds
R3(config-router)#no timers bgp 11 40
R3(config-router)#do clear ip bgp *
R3(config-router)#
%BGP-5-ADJCHANGE: neighbor 1.1.1.4 Down User reset
%BGP-5-ADJCHANGE: neighbor 1.1.1.4 Up
R3(config-router)#do show ip bgp neigh | in keep
Last read 00:00:13, last write 00:00:13, hold time is 180, keepalive interval
is 60 seconds
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:29, last write 00:00:29, hold time is 180, keepalive interval
is 60 seconds
R4(config-router)#timers bgp 10 59
R4(config-router)#do clear ip bgp *
R4(config-router)#
%BGP-5-ADJCHANGE: neighbor 1.1.1.3 Down User reset
R4(config-router)#
*Nov 17 16:43:13.489: %BGP-5-ADJCHANGE: neighbor 1.1.1.3 Up
R3(config-router)#do show ip bgp neigh | in keep
Last read 00:00:01, last write 00:00:01, hold time is 59, keepalive interval i
s 19 seconds
R4(config-router)#do show ip bgp neigh | in keep
Last read 00:00:12, last write 00:00:01, hold time is 59, keepalive interval i
s 10 seconds
Configured hold time is 59,keepalive interval is 10 seconds, Minimum holdtime
from neighbor is 0 seconds

Is there any more options you could see 🙂

A Networker Blog

OUT to, from R5

r5.jpg

In this topology We want to filter the 192.168.100.0 network from being redistributed into the OSPF topology. We also want to filter the other 192.168.x.0 networks with an odd third octet. We could use a route-map in our redistribution statement, but that is not the method that we are going to use here.

We need to permit several routes out to the OSPF neighbors. In order to filter these networks, we will need to be very specific with our access list. If we have two deny statements, the third statement can be a permit statement to allow all other networks to pass. The networks that we need to block are 192.168.100.0, 192.168.1.0, 192.168.3.0, and 192.168.5.0. We will block the 192.168.100.0 by itself, and we will need to block the .1, .3, and .5 networks in a single line. Let’s take a look at the binary for these three, and see how we can match all three in a single line.

1 – 0 0 0 0 0 0 0 1
3 – 0 0 0 0 0 0 1 1
5 – 0 0 0 0 0 1 0 1

The only bits that are different are the sixth and seventh bits. If we set these as don’t care bits, our mask will be:
0 0 0 0 0 1 1 0

This converts to 6 in decimal. Our second access list statement will deny 192.168.1.0 with a mask of 0.0.6.0

R5#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#access-list 89 deny 192.168.100.0
R5(config)#access-list 89 deny 192.168.1.0 0.0.6.0
R5(config)#access-list 89 permit any
R5(config)#router ospf 1
R5(config-router)#distribute-list 89 out eigrp 55
R5(config-router)#red eigrp 55 sub
R5(config-router)#

Ordinarily, you would not use an outbound distribute list with OSPF, because all routers in the area need to have the same link-state information. Since R5 is a redistributing router, it will affect which routes are redistributed from EIGRP into OSPF.

R1#show ip route 192.168.2.0
Routing entry for 192.168.2.0/24
Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 64
Last update from 143.2.153.5 on Serial0/0/0.1, 00:00:29 ago
Routing Descriptor Blocks:
* 143.2.153.5, from 100.5.5.5, 00:00:29 ago, via Serial0/0/0.1
Route metric is 20, traffic share count is 1

R1#show ip route 192.168.1.0
% Network not in table

A Networker Blog

area . nssa translate type7 suppress-fa and the FA Address

The OSPF Forwarding Address Suppression in Translated Type-5 LSAs feature causes
a not-so-stubby area (NSSA) area border router (ABR) to translate Type-7 link state
advertisements (LSAs) to Type-5 LSAs, but use the address 0.0.0.0 for the forwarding
address instead of that specified in the Type-7 LSA. This feature causes routers that
are configured not to advertise forwarding addresses into the backbone to direct
forwarded traffic to the translating NSSA ABRs

For Example:
SW1#show ip ospf database external 2.2.2.0

OSPF Router with ID (9.9.9.9) (Process ID 1)

Type-5 AS External Link States

Routing Bit Set on this LSA
LS age: 58
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 2.2.2.0 (External Network Number )
Advertising Router: 4.4.4.4
LS Seq Number: 80000001
Checksum: 0xAC5A
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 192.168.24.2 --------- Forwarding address
External Route Tag: 0
This could happen if you do not know how to reach the Forwarding address (192.168.24.2)
SW1#show ip route 192.168.24.2
% Network not in table

SW1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
Interface
4.4.4.4 1 FULL/BDR 00:00:32 192.168.14.4 Vlan14
1.1.1.1 255 FULL/DR 00:00:37 192.168.100.1
Vlan100
10.10.10.10 1 FULL/BDR 00:00:36 192.168.100.10
Vlan100

SW1#show ip ospf database

OSPF Router with ID (150.150.0.1) (Process ID 100)

OSPF Router with ID (9.9.9.9) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link
count
1.1.1.1 1.1.1.1 86 0x80000142 0x00BB4E 4
4.4.4.4 4.4.4.4 20 0x80000005 0x00EA1B 1
6.6.6.6 6.6.6.6 897 0x8000012B 0x005A47 3
9.9.9.9 9.9.9.9 25 0x80000143 0x006822 4
10.10.10.10 10.10.10.10 87 0x8000002B 0x00766C 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
192.168.14.10 9.9.9.9 26 0x80000001 0x00DB84
192.168.100.1 1.1.1.1 70 0x80000002 0x00F71A

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
2.2.2.0 4.4.4.4 16 0x80000001 0x00AC5A 0
The 192.168.24.2 was filtered,  lets look at the External OSPF database

SW1#show ip ospf database external 2.2.2.0

OSPF Router with ID (150.150.0.1) (Process ID 100)

OSPF Router with ID (9.9.9.9) (Process ID 1)

Type-5 AS External Link States

LS age: 23
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 2.2.2.0 (External Network Number )
Advertising Router: 4.4.4.4
LS Seq Number: 80000001
Checksum: 0xAC5A
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 192.168.24.2  --------- Forwarding address
External Route Tag: 0

SW1#show ip route 192.168.24.0
% Network not in table
SW1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
SW1#
We see that we still have the Forwarding Address there, even
if the route is not present in the Routing Table.

Not lets use the area . nssa translate type7 suppress-fa command

Serial0.42 from LOADING to FULL, Lo
R4(config-router)#router ospf 100
R4(config-router)#
R4(config-router)#area 42 nssa translate type7 suppress-fa
R4(config-router)#
SW1#show ip ospf database external 2.2.2.0

OSPF Router with ID (150.150.0.1) (Process ID 100)

OSPF Router with ID (9.9.9.9) (Process ID 1)

Type-5 AS External Link States

Routing Bit Set on this LSA
LS age: 8
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 2.2.2.0 (External Network Number )
Advertising Router: 4.4.4.4
LS Seq Number: 80000002
Checksum: 0x2564
Length: 36
Network Mask: /24
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 20
Forward Address: 0.0.0.0 --------- Forwarding address modified
External Route Tag: 0

SW1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 59/62/67 ms
SW1#

SW1#show ip route 2.2.2.2
Routing entry for 2.2.2.0/24
Known via "ospf 1", distance 110, metric 20, type extern 2, forward
metric 1
Last update from 192.168.14.4 on Vlan14, 00:02:09 ago
Routing Descriptor Blocks:
* 192.168.14.4, from 4.4.4.4, 00:02:09 ago, via Vlan14
Route metric is 20, traffic share count is 1

SW1#show ip route 0.0.0.0
% Network not in table
SW1#
In short, if routers do not have the knowledge on how to reach the forwarding address,
due to some kind of lsa filtering, you can suppress the FA route advertisement and suppress 
this value, this would results that the FA be equal to 0.0.0.0 which forces the use of 
the ASBR to reach the destination.

A Networker Blog

IPV6 & Multicast Routing

This configuration is based on this link

1.jpg

The requirement is to configure a Loopback0 on R3 and configure the following IPv6 Networks on R3 and R4.

The configuration on R3 is:

Loopback0    3:3:3:33::/64
Fast0/1    3:3:3:30::/64
Serial0/0/1    3:3:3:34::/64

The configuration on R4 is:
Fast0/0        3:3:3:40::/64
Serial0/0/1        3:3:3:34::/64

R3#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#
R3(config)#ipv6 unicast-routing
R3(config)#interface Loopback0
R3(config-if)#ipv6 address 3:3:3:33::/64 eui-64
R3(config-if)#interface FastEthernet0/1
R3(config-if)#ipv6 address 3:3:3:30::/64 eui-64
R3(config-if)#interface Serial0/0/1
R3(config-if)#ipv6 address 3:3:3:34::/64 eui-64
R3(config-if)#exit
R3(config)#^Z

R4#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#
R4(config)#ipv6 unicast-routing
R4(config)#interface FastEthernet0/1
R4(config-if)#ipv6 address 3:3:3:40::/64 eui-64
R4(config-if)#interface Serial0/0/1
R4(config-if)#ipv6 address 3:3:3:34::/64 eui-64
R4(config-if)#

Now we are going to configure RIPng and make sure R3 and R4 can ping all IPv6 networks

R3#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv6 unicast-routing
R3(config)#interface Loopback0
R3(config-if)#ipv6 rip Lab3 enable
R3(config-if)#interface FastEthernet0/1
R3(config-if)#ipv6 rip Lab3 enable
R3(config-if)#interface Serial0/0/1
R3(config-if)#ipv6 rip Lab3 enable
R3(config-if)#^Z

R4#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#
R4(config)#ipv6 unicast-routing
R4(config)#interface FastEthernet0/1
R4(config-if)#ipv6 rip Lab3 enable
R4(config-if)#interface Serial0/0/1
R4(config-if)#ipv6 rip Lab3 enable
R4(config-if)#^Z
R4#

We can check the routing and then perform a test ping from R4’s LAN to R3’s loopback.

R3#sh ipv6 route
IPv6 Routing Table – 9 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
C   3:3:3:30::/64 [0/0]
via ::, FastEthernet0/1
L   3:3:3:30:217:EFF:FE64:5B19/128 [0/0]
via ::, FastEthernet0/1
C   3:3:3:33::/64 [0/0]
via ::, Loopback0
L   3:3:3:33:217:EFF:FE64:5B18/128 [0/0]
via ::, Loopback0
C   3:3:3:34::/64 [0/0]
via ::, Serial0/0/1
L   3:3:3:34:217:EFF:FE64:5B18/128 [0/0]
via ::, Serial0/0/1
R   3:3:3:40::/64 [120/2]
via FE80::216:C7FF:FEBE:6D58, Serial0/0/1
L   FE80::/10 [0/0]
via ::, Null0
L   FF00::/8 [0/0]
via ::, Null0
R3#

R4#sh ipv6 route
IPv6 Routing Table – 8 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
R   3:3:3:30::/64 [120/2]
via FE80::217:EFF:FE64:5B18, Serial0/0/1
R   3:3:3:33::/64 [120/2]
via FE80::217:EFF:FE64:5B18, Serial0/0/1
C   3:3:3:34::/64 [0/0]
via ::, Serial0/0/1
L   3:3:3:34:216:C7FF:FEBE:6D58/128 [0/0]
via ::, Serial0/0/1
C   3:3:3:40::/64 [0/0]
via ::, FastEthernet0/1
L   3:3:3:40:216:C7FF:FEBE:6D59/128 [0/0]
via ::, FastEthernet0/1
L   FE80::/10 [0/0]
via ::, Null0
L   FF00::/8 [0/0]
via ::, Null0

Now we are configuring R3 and R4 for IPv6 multicast-routing. Also, we are going to Configure R4 to join group FF04::40 using its Fast0/0 interface and make sure R3 is the PIM DR on the Serial network.

To configure a router to do IPv6 multicast routing we first need to configure the following command.

R3#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ipv6 multicast-routing
R3(config)#^Z

R4#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#ipv6 multicast-routing
R4(config)#^Z

The host to router signaling in IPv6 multicast is performed by a protocol called Multicast Lister Discovery (MLD). Cisco IOS supports MLDv1 (similar to IGMPv2) and MLDv2 (similar to IGMPv3). Below command will configure R4’s Fast0/0 to join the requested group.

R4#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int f0/0
R4(config-if)#ipv6 mld join-group FF04::40

Note that unlike Ipv4 multicast, as soon as you configure IPv6 multicast routing all interfaces automatically run PIM-SM (IPv6 multicast only supports PIM-SM and PIM-SSM. No PIM-DM).

You can check your configuration using show ipv6 mroute

R4#show ipv6 mroute
Multicast Routing Table
Flags: D – Dense, S – Sparse, B – Bidir Group, s – SSM Group,
C – Connected, L – Local, I – Received Source Specific Host Report,
P – Pruned, R – RP-bit set, F – Register flag, T – SPT-bit set,
J – Join SPT
Timers: Uptime/Expires
Interface state: Interface, State

(*, FF04::40), 00:00:06/never, RP ::, flags: SCLJ
Incoming interface: Null
RPF nbr: ::
Immediate Outgoing interface list:
FastEthernet0/1, Forward, 00:00:06/never

Now we need to make sure R3 is the PIM DR. The default DR priority is 1 one so we will configure R3’s Serial0/0/1 interface to have a priority of 2 and then check to make sure it is the DR.

R3(config)#int s0/0/1
R3(config-if)#ipv6 pim dr-priority 2
R3(config-if)#exit
R3(config)#do sh ipv6 pim interface Serial0/0/1
Interface          PIM  Nbr   Hello  DR
Count Intvl  Prior

Serial0/0/1        on   1     30     2
Address: FE80::217:EFF:FE64:5B18
DR     : this system

R3  is going to work as a candidate BSR and candidate RP for groups in the range FF00::/8 using Loopback0 address as an ID.

Cisco IOS doesn’t support Auto-RP or at least not until 12.4T. It only supports BSR routers that look at candidate RP advertisements and send the mapping to the rest of the multicast routers.

The range specified in the question is in fact the whole IPv6 multicast range because an IPv6 Multicast address is identified by the first 8 bits being set (FF).

We will configure the commands below for BSR and RD candidature. Note that we don’t need to configure the Loopback interface for PIM because this happens automatically as soon as we configure IPv6 multicast.

R3(config)#ipv6 pim bsr candidate bsr  3:3:3:33:217:EFF:FE64:5B18 !Lo0
R3(config)#ipv6 pim bsr candidate rp  3:3:3:33:217:EFF:FE64:5B18
R3(config)#

We can confirm the configuration on R3 itself using the commands below.

R3#show ipv6 pim bsr candidate-rp
PIMv2 C-RP information
Candidate RP: 3:3:3:33:217:EFF:FE64:5B18 SM
All Learnt Scoped Zones, Priority 192, Holdtime 150
Advertisement interval 60 seconds
Next advertisement in 00:00:45

R3#show ipv6 pim bsr election
PIMv2 BSR information

BSR Election Information
Scope Range List: ff00::/8
BSR Address: ::
Uptime: 00:00:00, BSR Priority: 0, Hash mask length: 0
RPF: ::,
BS Timer: 00:00:21
This system is candidate BSR
Candidate BSR address: 3:3:3:33:217:EFF:FE64:5B18, priority: 0, hash mask length: 126

R3#sh ipv6 pim group-map info-source bsr

FF00::/8*
SM, RP: 3:3:3:33:217:EFF:FE64:5B18
RPF: Tu2,3:3:3:33:217:EFF:FE64:5B18 (us)
Info source: BSR From: 3:3:3:33:217:EFF:FE64:5B18(00:02:23), Priority: 192
Uptime: 00:00:06, Groups: 1

A Networker Blog

EIGRP Load Balancing.

Eigrp load balance with a variance = 1, meaning that Equal Cost FD is needed
in order to accomplish load balancing. The unequal-cost load-balancing with
EIGRP is subject to one aditional restriction, the  best metric is selected
(FD) and multiplied by the variance, so anything in that range will be used to
load balance over unequal cost path

Sw1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static
route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 2 subnets
C       1.1.17.0 is directly connected, FastEthernet0/1
C       1.1.27.0 is directly connected, FastEthernet0/2
12.0.0.0/32 is subnetted, 1 subnets
D       12.12.12.12 [90/156160] via 1.1.17.1, 00:01:34, FastEthernet0/1
Sw1#
Sw1#
Sw1#
Sw1#
Sw1#
rack10>2
[Resuming connection 2 to R2 … ]

R2#
R2#show ip eigrp inter
IP-EIGRP interfaces for process 1

Xmit Queue   Mean   Pacing Time   Multicast
Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                0        0/0         0       0/1            0           0
R2#conf te
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#do show run int f0/0
Building configuration…

Current configuration : 93 bytes
!
interface FastEthernet0/0
ip address 1.1.27.2 255.255.255.0
duplex auto
speed auto
end

R2(config)#router eigrp 1
R2(config-router)#net 1.1.27.2 0.0.0.0
R2(config-router)#do show ip eigrp inter
IP-EIGRP interfaces for process 1

Xmit Queue   Mean   Pacing Time   Multicast
Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                0        0/0         0       0/1            0           0
Fa0/0              0        0/0         0       0/1            0           0
R2#
rack10>3
[Resuming connection 3 to cat1 … ]

00:05:48: %DUAL-5
Sw1#
Sw1#show ip route eigrp
12.0.0.0/32 is subnetted, 1 subnets
D       12.12.12.12 [90/156160] via 1.1.27.2, 00:00:04, FastEthernet0/2
[90/156160] via 1.1.17.1, 00:00:04, FastEthernet0/1
Sw1#
Sw1#
Sw1#
Sw1#
Sw1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(1.1.27.7)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 12.12.12.12/32, 2 successors, FD is 156160
via 1.1.27.2 (156160/128256), FastEthernet0/2
via 1.1.17.1 (156160/128256), FastEthernet0/1
P 1.1.17.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 1.1.27.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/2
Sw1#! So for example we can modify the default calculation of EIGRP
Sw1#show ip proto | in K
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

To configure this in the routers you can use the:
Router(config-router)# metric weights tos k1 k2 k3 k4 k5

using the EIGRP well know formula if K5 is different than 0

metric = [K1*bandwidth + (K2*bandwidth)/(256 – load) + K3*delay] *
[K5/(reliability + K4)]

Sw1#conf te
Enter configuration commands, one per line.  End with CNTL/Z.
Sw1(config)#int f0/2
Sw1(config-if)#band 4
Sw1(config-if)#do show ip route eigrp
12.0.0.0/32 is subnetted, 1 subnets
D       12.12.12.12 [90/156160] via 1.1.17.1, 00:00:01, FastEthernet0/1
Sw1(config-if)#
rack10>1
[Resuming connection 1 to R1 … ]

*Apr 19 21:46:07.92
R1#
R1#show ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(12.12.12.12)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 12.12.12.12/32, 1 successors, FD is 128256
via Connected, Loopback0
P 1.1.17.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 1.1.27.0/24, 1 successors, FD is 640005120
via 1.1.17.7 (640005120/640002560), FastEthernet0/0
R1#

You can also load share over unequal cost paths. To do this we use the
variance feature in the EIGRP routing process. The variance is defined with a
multiplier that represents the difference between the metrics of the paths.
The default variance is ‘1’ which means that the multiple paths must have the
same metrics.

Also we can manipulate the BW + DLY, where the Bw(i) is the min bw and the Dly(i) is the sum of
delay, so for example is we nee to share traffic in 5:1 relationship

post1.jpg

Rack1R1#$rp topology 192.168.1.0 255.255.255.0 | in
(from|bandwidth|delay) 164.1.12.2 (Serial0/0), from 164.1.12.2, Send
flag is 0x0
*Minimum bandwidth is 256 Kbit*
Total delay is 25100 microseconds
164.1.13.3 (Serial0/1), from 164.1.13.3, Send flag is 0x0
*Minimum bandwidth is 256 Kbit*
Total delay is 45100 microseconds

http://www.cisco.com/warp/public/103/eigrp-toc.html

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009
437d.shtml#netdiag

Eigrp load balance with a variance = 1, meaning that Equal Cost FD is
needed in order to accomplish load balancing

To get your ratio problem you will need (Composite Metric of R3) *5 =
(Composite Metric of R1)* 1
Need to manipulate the BW or the DLY (by default) to make this happens
{(10e7/minbw + dly/10) * 256} *5 = {(10e7/minbw + dly/10)*256}*1
Since you need that the FDs of the neighbors be in in the variance
factor, in order to do unequal load balancing

Try to clear you Routing Table a couple of time because you are only
installing one path to the destination and the AD from R1 < FD to R3

A Networker Blog